re = /([^\p{L},\s])/
str = 'ssssss-sssss,.:;&7trfрполвлвшммьябфдовкуцй43231зжэээ сссби
лдрдрэ\'@#$^%$!)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end