import re
regex = re.compile(r"(ENERGIA ELETRICA CONSUMO(.|\n)*?%)", flags=re.MULTILINE)
test_str = ("\"5758 6128 370 kWh 1 370 kWh 11,93 kWh 12/07/2019 01/08/2019\n"
"Mês kWh Dt.Pgto. Valor\n"
"06/2019 355 17/06/2019 343,79\n"
"NOTA FISCAL/CONTA DE ENERGIA ELÉTRICA N° 085.976.711 - SÉRIE B\n"
"Emitida em 03/07/2019\n"
"05/2019 332 14/05/2019 306,84\n"
"Produto Valor Valor Base Aliq.\n"
"04/2019 415 29/05/2019 378,67\n"
"Descrição Un. Consumo Unitário Total Cálc. ICMS\n"
"03/2019 308 14/05/2019 269,81\n"
"ENERGIA ELETRICA CONSUMO kWh 370 0,787324 291,31 291,31 29,00%\n"
"02/2019 347 26/04/2019 305,09\n"
"ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00%\n"
"01/2019 341 11/03/2019 324,39\n"
"12/2018 301 26/12/2018 287,83\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)