import Foundation
let pattern = #"(ENERGIA ELETRICA CONSUMO(.|\n)*?%)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"5758 6128 370 kWh 1 370 kWh 11,93 kWh 12/07/2019 01/08/2019
Mês kWh Dt.Pgto. Valor
06/2019 355 17/06/2019 343,79
NOTA FISCAL/CONTA DE ENERGIA ELÉTRICA N° 085.976.711 - SÉRIE B
Emitida em 03/07/2019
05/2019 332 14/05/2019 306,84
Produto Valor Valor Base Aliq.
04/2019 415 29/05/2019 378,67
Descrição Un. Consumo Unitário Total Cálc. ICMS
03/2019 308 14/05/2019 269,81
ENERGIA ELETRICA CONSUMO kWh 370 0,787324 291,31 291,31 29,00%
02/2019 347 26/04/2019 305,09
ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00%
01/2019 341 11/03/2019 324,39
12/2018 301 26/12/2018 287,83"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)