const regex = /(1[0-2]|[1-9])[\s\\\/\.-](3[0-1]|[1-2][0-9]|[1-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(1[0-2]|[1-9])[\\s\\\\\\\/\\.-](3[0-1]|[1-2][0-9]|[1-9])', 'g')
const str = `Random Input
//
apples
100
10
Invalid Dates
1/0
1/1
1/9
1/10
1/19
1/20
1/29
1/30
1/31
1/32
Separators
10-10
10.10
10\\10
10/10
10a10
10%10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}