// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(1[0-2]|[1-9])[\s\\\/\.-](3[0-1]|[1-2][0-9]|[1-9])").unwrap();
let string = "Random Input
//
apples
100
10
Invalid Dates
1/0
1/1
1/9
1/10
1/19
1/20
1/29
1/30
1/31
1/32
Separators
10-10
10.10
10\\10
10/10
10a10
10%10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}