import re
regex = re.compile(r"(1[0-2]|[1-9])[\s\\\/\.-](3[0-1]|[1-2][0-9]|[1-9])")
test_str = ("Random Input\n"
"//\n"
"apples\n"
"100\n"
"10\n\n\n"
"Invalid Dates\n"
"1/0\n"
"1/1\n"
"1/9\n"
"1/10\n"
"1/19\n"
"1/20\n"
"1/29\n"
"1/30\n"
"1/31\n"
"1/32\n\n"
"Separators\n"
"10-10\n"
"10.10\n"
"10\\10\n"
"10/10\n"
"10a10\n"
"10%10\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")