#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(([\w\d]+\.)|(\*\.))+[\w\d]+$"
Local $sString = "correct:" & @CRLF & _
"" & @CRLF & _
"*.test.com" & @CRLF & _
"test.com" & @CRLF & _
"abc.test.com" & @CRLF & _
"" & @CRLF & _
"Incorrect:" & @CRLF & _
"*test.com" & @CRLF & _
"test.com*" & @CRLF & _
"test.*.com" & @CRLF & _
"test.abc*.com" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)