using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([\w\d]+\.)|(\*\.))+[\w\d]+$";
string substitution = @" ";
string input = @"correct:
*.test.com
test.com
abc.test.com
Incorrect:
*test.com
test.com*
test.*.com
test.abc*.com
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}