use strict;
my $str = 'correct:
*.test.com
test.com
abc.test.com
Incorrect:
*test.com
test.com*
test.*.com
test.abc*.com
';
my $regex = qr/^(([\w\d]+\.)|(\*\.))+[\w\d]+$/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";