#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^%\d]|^|\b(?=%))(?:%%)*(\d+)"
Local $sString = "abcd %1 %%2 %%%3 %%%%4 efgh" & @CRLF & _
"" & @CRLF & _
"abcd%12%%34%%%666%%%%11efgh" & @CRLF & _
"%%6%%7%%8" & @CRLF & _
"123" & @CRLF & _
"abc123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")