const regex = /(?:[^%\d]|^|\b(?=%))(?:%%)*(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^%\\d]|^|\\b(?=%))(?:%%)*(\\d+)', 'g')
const str = `abcd %1 %%2 %%%3 %%%%4 efgh
abcd%12%%34%%%666%%%%11efgh
%%6%%7%%8
123
abc123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}