re = /(?:[^%\d]|^|\b(?=%))(?:%%)*(\d+)/
str = 'abcd %1 %%2 %%%3 %%%%4 efgh
abcd%12%%34%%%666%%%%11efgh
%%6%%7%%8
123
abc123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end