using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+\s+:\s+name\s+:\s+(?<name>[^ ]+)\s+cpu:(?<cpu>[^ ]+)\s+memory:(?<memory>[^ ]+)\s+disk:(?<disk>.*)";
string input = @"process_1_details : name : msmg cpu:43% memory:4% disk:67%
process_2_details : name : hefe cpu:0% memory:8% disk:56%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}