$re = '/^\w+\s+:\s+name\s+:\s+(?<name>[^ ]+)\s+cpu:(?<cpu>[^ ]+)\s+memory:(?<memory>[^ ]+)\s+disk:(?<disk>.*)/m';
$str = 'process_1_details : name : msmg cpu:43% memory:4% disk:67%
process_2_details : name : hefe cpu:0% memory:8% disk:56%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);