const regex = /^\w+\s+:\s+name\s+:\s+(?<name>[^ ]+)\s+cpu:(?<cpu>[^ ]+)\s+memory:(?<memory>[^ ]+)\s+disk:(?<disk>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+\\s+:\\s+name\\s+:\\s+(?<name>[^ ]+)\\s+cpu:(?<cpu>[^ ]+)\\s+memory:(?<memory>[^ ]+)\\s+disk:(?<disk>.*)', 'gm')
const str = `process_1_details : name : msmg cpu:43% memory:4% disk:67%
process_2_details : name : hefe cpu:0% memory:8% disk:56%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}