$re = '/^(\d+|\w+@\w+\.com)$/m';
$str = 'abc@gmail.com
abcgmail.com
1234567890
123456789A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);