re = /^(\d+|\w+@\w+\.com)$/m
str = 'abc@gmail.com
abcgmail.com
1234567890
123456789A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end