#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((https|http):\/\/)?(www\.)?([\w-]{2,}\.[\w-]{2,3}\.[\w-]{2,3}|[\w-]{2,}\.[a-zA-Z]{2,3})(\/[a-z0-9]+(\.(php|html|asp|aspx))?)?$"
Local $sString = "https://www.page.com/about.php" & @CRLF & _
"https://www.page.com/about " & @CRLF & _
"https://www.page.com/ " & @CRLF & _
"www.page.com" & @CRLF & _
"page.com" & @CRLF & _
"page-10.com" & @CRLF & _
"1234.com" & @CRLF & _
"www.page" & @CRLF & _
"1234567._-d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")