import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((https|http):\\/\\/)?(www\\.)?([\\w-]{2,}\\.[\\w-]{2,3}\\.[\\w-]{2,3}|[\\w-]{2,}\\.[a-zA-Z]{2,3})(\\/[a-z0-9]+(\\.(php|html|asp|aspx))?)?$";
final String string = "https://www.page.com/about.php\n"
+ "https://www.page.com/about \n"
+ "https://www.page.com/ \n"
+ "www.page.com\n"
+ "page.com\n"
+ "page-10.com\n"
+ "1234.com\n"
+ "www.page\n"
+ "1234567._-d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}