import re
regex = re.compile(r"^((https|http):\/\/)?(www\.)?([\w-]{2,}\.[\w-]{2,3}\.[\w-]{2,3}|[\w-]{2,}\.[a-zA-Z]{2,3})(\/[a-z0-9]+(\.(php|html|asp|aspx))?)?$", flags=re.MULTILINE)
test_str = ("https://www.page.com/about.php\n"
"https://www.page.com/about \n"
"https://www.page.com/ \n"
"www.page.com\n"
"page.com\n"
"page-10.com\n"
"1234.com\n"
"www.page\n"
"1234567._-d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")