using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(([\s]*(?:and|or|not)?[\s]*([\w]+)[\s]+(?:eq|ne|gt|ge|lt|le)[\s]+(?:""(?:[^""\\]|\\.)*""|\d+(,\d+)*(\.\d+(e\d+)?)?|null)[\s]*|(?R))*\))";
string input = @"((priority eq ""123"" or en eq 34) and pre eq 1)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}