const regex = /(\(([\s]*(?:and|or|not)?[\s]*([\w]+)[\s]+(?:eq|ne|gt|ge|lt|le)[\s]+(?:"(?:[^"\\]|\\.)*"|\d+(,\d+)*(\.\d+(e\d+)?)?|null)[\s]*|(?R))*\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(([\\s]*(?:and|or|not)?[\\s]*([\\w]+)[\\s]+(?:eq|ne|gt|ge|lt|le)[\\s]+(?:"(?:[^"\\\\]|\\\\.)*"|\\d+(,\\d+)*(\\.\\d+(e\\d+)?)?|null)[\\s]*|(?R))*\\))', '')
const str = `((priority eq "123" or en eq 34) and pre eq 1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}