re = /(\(([\s]*(?:and|or|not)?[\s]*([\w]+)[\s]+(?:eq|ne|gt|ge|lt|le)[\s]+(?:"(?:[^"\\]|\\.)*"|\d+(,\d+)*(\.\d+(e\d+)?)?|null)[\s]*|(?R))*\))/
str = '((priority eq "123" or en eq 34) and pre eq 1)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end