#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "bannerDomain=(.+)"
Local $sString = "lineItem=USA~ACQ~AppNexus~PD~interscroller~D_M~lifestyle~ADF-10900-0221a|bannerDomain=marieclaire.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")