package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`bannerDomain=(.+)`)
var str = `lineItem=USA~ACQ~AppNexus~PD~interscroller~D_M~lifestyle~ADF-10900-0221a|bannerDomain=marieclaire.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}