$re = '/bannerDomain=(.+)/';
$str = 'lineItem=USA~ACQ~AppNexus~PD~interscroller~D_M~lifestyle~ADF-10900-0221a|bannerDomain=marieclaire.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);