#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^COD(?:(?!00)[0-9]{2}|0)$"
Local $sString = "COD00" & @CRLF & _
"COD09" & @CRLF & _
"COD11" & @CRLF & _
"COD10" & @CRLF & _
"COD20" & @CRLF & _
"COD0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")