using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^COD(?:(?!00)[0-9]{2}|0)$";
string input = @"COD00
COD09
COD11
COD10
COD20
COD0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}