$re = '/^COD(?:(?!00)[0-9]{2}|0)$/m';
$str = 'COD00
COD09
COD11
COD10
COD20
COD0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);