#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<!--(?!\s*(?:\[if [^\]]+]|<!|>))(?:(?!-->)(.|\n))*-->"
Local $sString = "<!-- some comments 1 -->" & @CRLF & _
"<!-- 1.91 -->" & @CRLF & _
"<!--" & @CRLF & _
"//-->" & @CRLF & _
"<!-- -->" & @CRLF & _
"" & @CRLF & _
"<!--[if IE]> <![endif]-->" & @CRLF & _
"<!--[if !IE]><!--> <!--<![endif]-->" & @CRLF & _
"<!--[if IE 6]> <![endif]-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")