import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--(?!\\s*(?:\\[if [^\\]]+]|<!|>))(?:(?!-->)(.|\\n))*-->";
final String string = "<!-- some comments 1 -->\n"
+ "<!-- 1.91 -->\n"
+ "<!--\n"
+ "//-->\n"
+ "<!-- -->\n\n"
+ "<!--[if IE]> <![endif]-->\n"
+ "<!--[if !IE]><!--> <!--<![endif]-->\n"
+ "<!--[if IE 6]> <![endif]-->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}