#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?:^\h*(?:\/\/|[#;])[^\n]*|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/)(*SKIP)(*F)|^\s*([^=\n]+?)\s*=\s*(.*?);\h*(?:$|\r?\n)"
Local $sString = "/*" & @CRLF & _
"anything description" & @CRLF & _
"*/" & @CRLF & _
"// Some=comment" & @CRLF & _
";Another = comment" & @CRLF & _
"# and this comment = too" & @CRLF & _
"" & @CRLF & _
"Data1 = value1;" & @CRLF & _
"" & @CRLF & _
"OtherData<> = Other Value;" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"my other description" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"Any thing = Any " & @CRLF & _
"Answer;" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"" & @CRLF & _
"this is description and must not detect" & @CRLF & _
"" & @CRLF & _
"Description_Data = Any_Value;" & @CRLF & _
"" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")