using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)(?:^\h*(?:\/\/|[#;])[^\n]*|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/)(*SKIP)(*F)|^\s*([^=\n]+?)\s*=\s*(.*?);\h*(?:$|\r?\n)";
string input = @"/*
anything description
*/
// Some=comment
;Another = comment
# and this comment = too
Data1 = value1;
OtherData<> = Other Value;
/*
my other description
*/
Any thing = Any
Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}