const regex = /(?sm)(?:^\h*(?:\/\/|[#;])[^\n]*|\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/)(*SKIP)(*F)|^\s*([^=\n]+?)\s*=\s*(.*?);\h*(?:$|\r?\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)(?:^\\h*(?:\\\/\\\/|[#;])[^\\n]*|\\\/\\*[^*]*\\*+(?:[^\\\/*][^*]*\\*+)*\\\/)(*SKIP)(*F)|^\\s*([^=\\n]+?)\\s*=\\s*(.*?);\\h*(?:$|\\r?\\n)', 'g')
const str = `/*
anything description
*/
// Some=comment
;Another = comment
# and this comment = too
Data1 = value1;
OtherData<> = Other Value;
/*
my other description
*/
Any thing = Any
Answer;
/*
this is description and must not detect
Description_Data = Any_Value;
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}