using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.)(?=(\d*(?:\(\d+\)\d*)*))\1$";
string input = @"123(432)123(342)2348(34)230948290384023894203842038940)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}