const regex = new RegExp('^(?=.)(?=(\\d*(?:\\(\\d+\\)\\d*)*))\\1$', '')
const str = `123(432)123(342)2348(34)230948290384023894203842038940)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}