$re = '/^(?=.)(?=(\d*(?:\(\d+\)\d*)*))\1$/';
$str = '123(432)123(342)2348(34)230948290384023894203842038940)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);