using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<a\s+(?:[^>]*)?href=""|(?!^)\G)\K.*?([A-Z]?\d{5}).*?(?="")";
string input = @"<a href=""/uploads/2014/04/Draft-99990-Details.doc"">Draft 99995 Details</a>
<a href=""/uploads/2014/04/01090-vs-G01010-series.pdf"">01095 vs G01015 Series</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}