# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<a\s+(?:[^>]*)?href=\"|(?!^)\G)\K.*?([A-Z]?\d{5}).*?(?=\")"
test_str = ("<a href=\"/uploads/2014/04/Draft-99990-Details.doc\">Draft 99995 Details</a>\n"
"<a href=\"/uploads/2014/04/01090-vs-G01010-series.pdf\">01095 vs G01015 Series</a>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.