import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<a\\s+(?:[^>]*)?href=\"|(?!^)\\G)\\K.*?([A-Z]?\\d{5}).*?(?=\")";
final String string = "<a href=\"/uploads/2014/04/Draft-99990-Details.doc\">Draft 99995 Details</a>\n"
+ "<a href=\"/uploads/2014/04/01090-vs-G01010-series.pdf\">01095 vs G01015 Series</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}