package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:]*\:){3}([^:]*)`)
var str = `1.1:ProvCM:111111111111:10.15.194.25:10.100.10.3:10.100.10.1:docsis3.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}