import re
regex = re.compile(r"^(?:[^:]*\:){3}([^:]*)", flags=re.MULTILINE)
test_str = "1.1:ProvCM:111111111111:10.15.194.25:10.100.10.3:10.100.10.1:docsis3.0"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")