use strict;
my $str = '1.1:ProvCM:111111111111:10.15.194.25:10.100.10.3:10.100.10.1:docsis3.0';
my $regex = qr/^(?:[^:]*\:){3}([^:]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}