using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{.*? => ([^}]+?)}";
string substitution = @"$1";
string input = @"""9 1 {Folder_Old => Folder}/FileTest1.cs""
""0 9 File{a => t}est2.cs""
""- - F{a => i}leT{b => e}st.d{c => l}l""
""9 1 {test/File.cs => test/File1.cs}"" ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}