$re = '/{.*? => ([^}]+?)}/mi';
$str = '"9 1 {Folder_Old => Folder}/FileTest1.cs"
"0 9 File{a => t}est2.cs"
"- - F{a => i}leT{b => e}st.d{c => l}l"
"9 1 {test/File.cs => test/File1.cs}" ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;