package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\S+`)
var str = `$4,233.65 $5,073.64 $9,307.29 $9,273.41 $0.00 $0.00 $33.88`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}