$re = '/\$\S+/m';
$str = '$4,233.65 $5,073.64 $9,307.29 $9,273.41 $0.00 $0.00 $33.88';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);