const regex = /\$\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\S+', 'gm')
const str = `\$4,233.65 \$5,073.64 \$9,307.29 \$9,273.41 \$0.00 \$0.00 \$33.88`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}