const regex = /(?<=,\s*)(?:([A-Z])\.?[a-üA-Z{\\'}]*(?:(-)| )?)(?:([A-Z])(\.?)[a-üa-zA-Z{\\'}]*(?:(-)| )?)?(?:([A-Z])(\.)?[a-zA-Z{\\'}]*(?:(-)| )?)?(?= and|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=,\\s*)(?:([A-Z])\\.?[a-üA-Z{\\\\\'}]*(?:(-)| )?)(?:([A-Z])(\\.?)[a-üa-zA-Z{\\\\\'}]*(?:(-)| )?)?(?:([A-Z])(\\.)?[a-zA-Z{\\\\\'}]*(?:(-)| )?)?(?= and|$)', 'gm')
const str = `Copiez votre liste d'auteur ici. Elle doit être sous la forme
Bennett, Elena M. and Baird, Julia and Baulch, Helen and Chaplin-Kramer, Rebecca and Fraser, Evan and Loring, Phil and Morrison, Peter and Parrott, Lael and Sherren, Kate and Winkler, Klara J. and Cimon-Morin, Jérôme and Fortin, Marie-Josée and Kurylyk, Barret L. and Lundholm, Jeremy and Poulin, Monique and Rieb, Jesse T. and Gonzalez, Andrew and Hickey, Gordon M. and Humphries, Murray and Krishna {Bahadur KC} and Lapen, David
Certain prénoms composés (ici Ruel, Jean-Claude) doivent être terminé à l'aide du deuxième outil:
`;
const subst = `$1.$2$3$4$5$6$7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);