use strict;
my $str = '*
\\*
\\\\*
\\\\\\*
\\\\\\\\*';
my $regex = qr/^([^\\\n]*(?:\\\\)*)\*/mp;
my $subst = '$1%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";